Summary: Problems with OW3 on SPARC 1

From: Larry Chin (larry@cchtor.uucp)
Date: Thu Apr 02 1992 - 08:06:35 CST

My original post:

> Hello all,
> Once again I turn to the list for an answer.
> I recently installed OW v1.3 on the sparc 1 and 2 machines here. The
> installation on the Sparc 2's is no problem, but the two Sparc 1 machines
> give the following error:
> System Warning: Object 0x16570
> Permission denied ioctl TIOCCONS returned -1 attempt to make
> TTY the console failed ( TTY package ).
> I followed all the install directions to the letter, but I still have
> not been able to get rid of this error.
> OW does start up after the display of this error by the way.
> we are running 4.1.2 and one sparc 1 has a cgthree frame buffer and the
> other a bwtwo.
> As I said the sparc 2`s show no signs of this problem.

I got 4 replies:

As it turns out, the permissions on /dev/console have to be such that
the user trying to start the OW session owns this device. This
was suggested by Greg Jumper and David Boyd.

1) (Brian J. Kennedy) suggested I get the patch

   I will.

2) (Greg Jumper) suggested that running OW3 with xdm
   and starting a console window without the user owning the console
   device could cause this problem and/or when OW is not running with
   the console as the controlling terminal.

   The former turned out to the correct answer.

3) (David Boyd) suggested checking the
   permissions on /dev/console. This is related to #2 above.

4) Brent Alan Wiese <> also suggested a
   check of the permissions on /dev/console and as well as a comparison
   of /etc/fbtab files between working and non-working systems.

Thanks to y'all who took the time to reply. I appreciate the help.

Larry Chin {} CCH Canadian Ltd.
System Administrator 6 Garamond Court
Research and Development Don Mills, Ontario.
(416) 441-4001 ext. 349 M3C 1Z5

These are my opinions, MINE YOU HEAR, MINE !!!

This archive was generated by hypermail 2.1.2 : Fri Sep 28 2001 - 23:06:40 CDT