Solaris 8 and AppleTalk

Michael Sullivan mps at blackbird.discomsys.com
Mon Oct 15 00:38:28 EDT 2001


Hello,

I'm having a problem getting Netatalk to run correctly on Solaris 8 with
a 64 bit kernel. (Solaris 8 (7/01).

I've scoured the internet and have found out a number of things.

1. GCC 2.95.3 does *NOT* produce 64 bit code.

2. GCC 3.0.2 produces 64 bit code ( sparcv9 ).

I am using GCC 3.0.2.

Tried netatalk-1.4b2+asun2.1.4 and netatalk-1.4b2+asun2.1.3.


I've tried building the ddp driver a number of ways.  This is the
message I'm getting:

valkyrie:/# add_drv -v -m '* 0666 root sys' ddp
exit status = 0
devfsadm: driver failed to attach: ddp
exit status = 11
Warning: Driver (ddp) successfully added to system but failed to attach
Driver (ddp) installed.


I've used different combinations of GCC KCFLAGS in the
${NETATTALK_SRC}/sys/solaris/Makefile

KCFLAGS= -D_KERNEL -Wall -Wstrict-prototypes ${KGCCFLAGS} -mcpu=v9

KCFLAGS= -D_KERNEL -Wall -Wstrict-prototypes ${KGCCFLAGS} -mcpu=v9 -m64

KCFLAGS= -D_KERNEL -Wall -Wstrict-prototypes ${KGCCFLAGS} -mcpu=v9 -m32

All seem to produce a 64 bit ELF executable.

I've tried using gas and the Solaris 8 bundled assembler, and both have
the same results.

[mps at valkyrie mps]$ ld -V
ld: Software Generation Utilities - Solaris-ELF (4.0)

[mps at valkyrie mps]$ /usr/local/bin/ld --version
GNU ld 2.11.2
Copyright 2001 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
  Supported emulations:
   elf32_sparc
   elf64_sparc



I'm using the latest binutils - binutils-2.11.2.  (At least it was a
month or so ago...)


My question is this: Has *anyone* built this successfully using any of
the combinations of software and had it work?

If so, how did you do it?  

Am I doomed to get a 30 day evaluation of Sun's Forte Developer 6 C and
C++?

I'd like to avoid the last option of the 30 day trial license.  Are
there any other free solutions available (*Other* than CAP - which I
haven't been able to get to compile under Solaris 8 - just plain doesn't
build all its executables and I've had to fix its make files and
libraries.  Other stuff just plain fails because it can't work with the
DLPI headers on Solaris 8.)

This is for home.  I'd like to avoid commercial options (AppleTalk IP,
and others) since they seem to have hefty licensing fees and all I want
to do with the Mac is print and share files.  It's actually my
girlfriend's Mac, she wants to be able to use the color printer attached
to the Sun box, and I'd like her to stay my girfriend.  Believe me this
will go along way in keeping the peace in the house.

Much thanks in advance...

Mike

-- 
Michael P. Sullivan                                  
Distributed Computing Systems, LLC                         Cell: 516-429-2080 
E-Mail: mps at discomsys.com                           http://www.discomsys.com/ 
    * UNIX Systems and Database Consulting, Architecture and Management *
"Failing to plan, is planning to fail... plan for the worst, hope for the best"



More information about the sunmanagers mailing list