Problem with cron...

Don Mies dmies at bluekite.com
Tue Oct 23 16:22:48 EDT 2001


I'm having a problem with cron on one of my machines.  It works fine
on all the other machines I have tried it on except this particular
one.

I have a very simple script:

------

#! /bin/sh

echo "This is a test at `date`" >> /tmp/cronTest

------

The crontab entry for this test is:

0,5,10,15,20,25,30,35,40,45,50,55 * * * * /export/home/user/cronTest


This crontab entry should run the above script every 5 minutes.

I get NOTHING in the /tmp/cronTest file.  In fact, the file is never
even created.

The /var/cron/log file looks like:

------

! unexpected pid returned 13516 (ignored) Tue Oct 23 13:00:01 2001
! unexpected pid returned 13554 (ignored) Tue Oct 23 13:05:00 2001
! unexpected pid returned 13760 (ignored) Tue Oct 23 13:10:00 2001

------
   
If I run the crontab as root, I get absolutely nothing but if I run   
it as a user, I get a mail message sent to me that says:

------

Subject: Couldn't run your "cron" job
Content-Length: 118

Your "cron" job on kuna couldn't be run
can't set project id for your job.
The error was "No such file or directory"

------

I have no idea what it means by "project id" in the above email.

Can anyone shed any light on this?

Thanks in advance!


Don



More information about the sunmanagers mailing list