SUMMARY: Custom Jumpstart going interactive.

Robert Brockway robert at timetraveller.org
Thu Oct 31 03:52:06 EST 2002


Thanks to Richard Skelton, Andy Lee, D Dunham, S Watkins, Paul Greidanus,
and Bill Welliver for their responses.

It turns out that two different changes were needed to completely solve my
problem.

1.  A number of people pointed out I was not using the "netmask" option in
the sysidcfg file.  This had originally been by design as I was using the
dhcp option to try to get info from there.  The netmask & dhcp options are
incompatible.  I had tried the netmask option first off but at that stage
there were other problems in the config so I had gone over to using the
dhcp option without being aware I had actually made the problem worse :)

Anyway, I changed back to using the netmask option and it stopped
prompting for the netmask to be entered manually (makes sense :)

2.  The 2nd problem related to being prompted for dns information when it
was seemingly un-necessary.  Paul Greidanus correctly pointed out that
Jumpstart prompts for dns information (most of which only goes into
/etc/resolv.conf) if it does not see the client information in the dns.

I made sure our dns was updated with an A record for the client and all of
the problems went away.

Thanks to everyone who posted.  It has been a great help.

Cheers,
	-Rob

-- Robert Brockway B.Sc. email: robert at timetraveller.org  ICQ: 104781119
   Linux counter project ID #16440 (http://counter.li.org)
   "The earth is but one country and mankind its citizens" -Baha'u'llah



More information about the sunmanagers mailing list