Cannot create SSLMutex

William Robertson willi_robs at yahoo.com
Tue Sep 30 18:27:02 EDT 2003


Hello SunManagers

I am trying to build a secured apache site using
openssl and chroot: 

-	Httpd-2.0.47
-	OpenSSL 0.9.7b
-	Chroot

When I run httpd using ssl without chroot things work
fine, and when I run httpd using chroot without ssl
things work fine also. The problem that I have is when
I try to chroot httpd and use ssl at the same time,
httpd wont start. The error message from the
/usr/local/apache/log file I get says No such file
or directory: Cannot create SSLMutex. 

So I decided to do the followings:
-	Created the file /apache/logs/ssl_mutex but I keep
getting the same error message.
-	Modified the .../apache/conf/ssl.conf and uncomment
the line that says SSLMutex file:logs/ssl_mutex but
keep getting the same message. I even changed this
SSLMutex file:/full_path/logs/ssl_mutex but keep
getting the same message. Somehow I think this line is
being ignored but I dont know why I keep getting the
same error message.

This is the command that I use to run httpd:
chroot /chroot/httpd/   /usr/local/apache/bin/httpd
-DSSL

So, is it possible that I can chroot an httpd with ssl
capability? If yes, what I am doing wrong? Eventhough
I found some information on Google about SSLMutex,
none has solved my problem

Thank you


__________________________________
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search
http://shopping.yahoo.com



More information about the sunmanagers mailing list