help with workstation problem -- urgent

Adam Levin levins at westnet.com
Tue Jun 7 09:59:59 EDT 2005


I've got a Sun Blade 100 workstation running Solaris 8 on my desk.  I run 
CDE (version 1.4) on it.

Last Friday, I did a "reload workspace manager", and my front panel switch 
went wiggy, so I tried logging out and logging back in.

I get an error:
---
The DT messaging system could not be started.
To correct the problem:
1) Choose OK to return to the login screen
2) Select failsafe session from the login screen's option menu and log in.
3) Check to see that the hostname is correct in these locations:
/etc/src.sh
/etc/hosts
/usr/adm/inetd.sec

For additional information, see the DT User's Guide.
---

/etc/hosts is correct, but /etc/src.sh and /usr/adm/inetd.sec don't exist 
and never have.

I decided since the system wasn't working I'd go ahead and install the 
latest patchcluster, which I did.

I'm still getting the problem.

Some google research shows that the error can be misleading, and that rpc 
must be running.  In my case, however, rpcbind *is* running.

There's a ToolTalk line in inetd.conf.  I've tried both with and without 
this service commented out, same results.

I cannot log in as my usual user, but root can log in under CDE.  I can 
log in fine on the console.

So, some permission must be screwy somewhere?  Has anyone seen this 
problem before?

-Adam



More information about the sunmanagers mailing list