DiskSuite Issue on Solaris 2.6

Bhavesh Shah bshah at citadon.com
Wed Jun 8 20:44:46 EDT 2005


Hi Gurus,

I have Netra box with two D1000 attached running  Solaris 2.6. I have
installed Disksuite 4.2 and have created two Metadevice  with RAID- 5 on
each D1000. One week back I lost One Disk with error (Need Maintenance)
and other with "Last Erred". As per Sun Documentation I replaced the
disk with error "Need Maintenance" first and resynced but after
resyncing it again showed the same error "Maintenance" I put another
Disk and tried to resync but no luck. At last I use another slot from
D1000 (one Slot was HotSpare) and tried to resync but it seems it
doesn't come as Good after resync is done. I can still see the Data on
D1000. What could be the issue? I have 160 GB of Data sitting on this
D1000. Other D1000 attached to same Box is working fine.

procedure what i did:



After putting the new Disk and creating partition in the same slot I ran


 ./metareplace -e d1 c2t3d0s0 - after resync was complete it again
went  back to Maintenance mode
then I did tried with HotSpare Slot Disk (after partitioning the   disk)

 ./metareplace -f d1 c2t3d0s0 c2t13d0s0 - after resync was complete it
again went back to Maintenance mode
Below is the output from metadevice:

	d1: RAID

	    State: Needs Maintenance

	    Invoke: metareplace -f d1 c2t3d0s0 <new device>

	    Hot spare pool: hsp002

	    Interlace: 32 blocks

	    Size: 353442528 blocks

	Original device:

	    Size: 353443520 blocks

	        Device              Start Block  Dbase State        Hot
Spare

	        c2t0d0s0                 330     No    Okay

	        c2t1d0s0                 330     No    Okay

	        c2t2d0s0                 330     No    Okay

	        c2t3d0s0                 330     No    Maintenance

	        c2t4d0s0                 330     No    Okay

	        c2t5d0s0                 330     No    Okay

	        c2t8d0s0                 330     No    Okay

	        c2t9d0s0                 330     No    Last Erred

	        c2t10d0s0                330     No    Okay

	        c2t11d0s0                330     No    Okay

	        c2t12d0s0                330     No    Okay



	Any Help/Pointer will be appreciated.

	I will summarize.

	TIA

	B



More information about the sunmanagers mailing list