Problems patching a Sun Netra T1

Gene Beaird bgbeaird at sbcglobal.net
Mon Mar 5 11:27:09 EST 2007


I was attempting to patch a system over the weekend that just  
wouldn't let me patch.  Im not sure if it is a disk issue, or what,  
because the system just hung when trying to patch, no error messages,  
or anything.  Please read below and let me know if you have any  
suggestions.

The system is a Netra T1 running Solaris 8.  It requires the 2 DST
patches (timezone and lib c) as well as six of their dependencies, and
at least three more dependencies from some of those dependencies.

The system has 512 MB of RAM, and the following filesystem space
utilization:

/ 156 MB free
/usr 559 MB free
/var 796 MB free
/opt 368 MB free

When I brought the system down to single-user mode to patch, I tried a
patch that had a dependency.  The system told me that, and terminated
the patch session.  I then tried another patch.  After checking for
installed patches and starting the 'determining disk space, dry run
method', the patch session just hung.  Thinking it may be a disk space
issue, I aborted that patch and tried another one that was much smaller.
Same thing happened again.

With 12 patches to install, and already an hour out of the maintenance
window, I quit the patch session.

Another thing of note:  When in single user mode, when attempting to do
an ls -al on the subdir I had the patches in, the list hung before
returning any of the patch directories.  I could completely list the
contents of that subdir when the system was running in multi-user mode,
although it was kind of jerky returning the list, sort of like it was
very busy.

I did unmount and fsck the partition with no problem.  Any thoughts?

Gene Beaird
Unix Support Engineer,
Pearland, Texas



More information about the sunmanagers mailing list